New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
gh-54781: Move Lib/tkinter/test/test_ttk/ to Lib/test/test_ttk/ #94070
Conversation
I can still run tests on an newly installed (patched) Python 3.12:
|
For me, it's disturbing when tests don't have the same name than the tested module. asyncio => test_asyncio. tkinter => test_tk ???
I can keep test_ttk_guionly name if you prefer, but for me, tests should use the GUI. Only the special tests test_ttk_textonly should have a special name, no? |
This PR is special. I made the new directory tree "flat". Before:
After:
|
Windows (x64) job failed but I cannot get the logs. I cancelled the workflow. I still cannot see the logs. Strange. |
Oh. Windows build failed with an unrelated error: Error: D:\a\cpython\cpython\Modules\socketmodule.c(7475,5): error C2065: 'HVSOCKET_CONTAINER_PASSTHRU': undeclared identifier [D:\a\cpython\cpython\PCbuild_socket.vcxproj] |
Yeah, seems we're in the middle of the rollout of new CI images, so there's a chance you'll get the older image and not see the error. But you'll need my PR for it to be reliable. |
Lib/test/test_tkinter/__init__.py
Outdated
|
||
if __name__ == '__main__': |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Does python -m test.test_tkinter
still work?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
It would work if a __main__
module gets added. But it was test.test_tk
before, not test.test_tkinter
.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Ah you care about this command? If you do, I can add a __main__.py
file.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Yes, please add it. And test different ways of running tests:
python -m test.test_xxx
python -m unittest test.test_xxx
python -m test test_xxx
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I added __main__
sub-modules. Example:
./python -m test.test_ttk -v
./python -m test test_ttk -v -u all
./python -m unittest test.test_ttk -v
The 3 commands end with: Ran 308 tests
.
if __name__ == '__main__': | ||
unittest.main() | ||
def load_tests(*args): | ||
return support.load_package_tests(os.path.dirname(__file__), *args) |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Why not use just loader.discover()
?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I copy/paste the code from test_asyncio, it works, so I didn't change it :-)
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Does loader.discover()
work with zipimport?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Does loader.discover() work with zipimport?
I have no idea. If there is an issue, I suggest to fix all load_tests() functions of Lib/test/ in a separated PR.
Should it be backported? |
I would prefer that ttk tests be included under test_tkinter, with names like |
This patch will require changes to the scripts *nix distributions use to make tkinter (and IDLE) a separate install. I don't know how they would feel about backports. |
I rebased the PR to get the fix for the Windows build: #94068 |
This specific PR change the name of two tests, so no, it should not be backported. It also changes the build system (Linux, VS project). Honestly, it sounds risky and I would prefer to not backport it. |
Oh. I tried to minimize changes in this PR. But I'm open to reorganizing tests. @serhiy-storchaka: Are you fine with the 2 proposed tests, or do you want to merge them? |
Once issue #54781 will be fixed, I will properly document these changes in What's New in Python 3.12. IMO it fits into the Build Changes section. |
I was going to ask about merging them, but I am fine with the current state of this PR. If you are going to merge Maybe do this in a separate PR? |
Oh, merging 3 Tkinter tests sound out of my skills. I don't know well this module and I would prefer if someone else do it. Here I'm trying to focus on fixing the 12 years old issue #54781 :-) Perfect is the enemy of good ;-) |
@serhiy-storchaka: Does it look good to you like that? |
@serhiy-storchaka wrote "I am fine with the current state of this PR". I plan to merge the PR tomorrow if I don't hear back from @serhiy-storchaka. |
* Add Lib/test/test_ttk/__init__.py based on test_ttk_guionly.py. * Remove Lib/test/test_ttk_guionly.py.
Remove Lib/test/test_tk.py.
Fix spelling typo: involving (missing G) Remove useless "if __name__ == '__main__':" block from Lib/test/test_ttk/__init__.py: the package has a __main__.py sub-module.
LGTM.
But I see that Git does not recognize renaming of test_tk.py. It breaks history and future backports. Can something be done with this?
I didn't rename test_tk.py to test_tkinter/init.py. I removed test_tk.py and copied test_asyncio/init.py to test_tkinter/init.py, and then modified test_tkinter/init.py. test_tk.py was just 18 lines of code, I don't think its file history was very important. |
On the other side, |
Move Lib/tkinter/test/ to Lib/test/test_tkinter/.
Rename test_tk to test_tkinter, and rename test_ttk_guionly to test_ttk.